FAQ #2544
Artikel editieren
Artikel weiterleiten

Qu'est-ce que le PHP Extended Support de STRATO ?

TABLE DES MATIÈRES

Qu'est-ce que PHP et quel rôle joue-t-il dans votre site web ?
Vous utilisez encore une version obsolète de PHP ?
Pourquoi avez-vous besoin du PHP Extended Support de STRATO ?
Quand avez-vous été informé du PHP Extended Support de STRATO ?
Pourquoi le PHP Extended Support de STRATO est-il payant ?
Quand débute le PHP Extended Support de STRATO ?
Vous n'êtes pas sûr d'avoir besoin du PHP Extended Support ?
Vous souhaitez adapter vos scripts à une version PHP supérieure mais vous avez besoin de plus de temps ?
Comment désactiver STRATO PHP Extended Support ? 

 

Qu'est-ce que PHP et quel rôle joue-t-il dans votre site web ?

PHP es un langage de script polyvalent servant de base à de nombreux sites web dynamiques et systèmes de gestion de contenu tels que WordPress, Joomla et Prestashop. La communauté PHP développe toujours PHP comme langage de programmation : elle offre de nouvelles fonctions et fonctionnalités et résout les vulnérabilités.

 

Qu

 

La communauté PHP a cessé d'offrir le support de PHP 5.3 le 14 août 2014. Ainsi, cette version n'est plus développée par la communauté PHP et les vulnérabilités ne sont plus corrigées. Nous avons continué à vous offrir ce service de maintenance malgré le coût que cela représentait en termes de personnel.

 

Qu

 

Vous utilisez encore une version obsolète de PHP ?

Vous avez donc reçu un e-mail vous informant que nous vous offrons désormais ce support technique (par exemple, les patches de sécurité) dans le cadre du PHP Extended Support de STRATO. Le PHP Extended Support est une prestation payante que nous mettons à votre disposition à partir du 01.12.2019. Vos sites web seront alors protégés des attaques et vous pourrez passer tranquillement à une version PHP à jour.

 

Pourquoi avez-vous besoin du PHP Extended Support de STRATO ?

Nous avons détecté des contenus PHP dans la version obsolète 7.1 de votre espace web. La raison est que vous avez configuré une version PHP obsolète à travers l'Espace client ou lors de l'usage d'un fichier .htaccess.

 

Nous vous expliquons comment modifier la configurat

ion dans votre Espace client: Comment modifier la configuration PHP dans votre pack Hébergement.

 

Nous vous conseillons de toujours utiliser une version PHP à jour. La version conseillée en ce moment est PHP 7.3. Vous pourrez ainsi utiliser les dernières versions des applications les plus populaires sans problèmes de compatibilité.

 

Qu

 

Quand avez-vous été informé du PHP Extended Support de STRATO ?

Nous vous avons envoyé récemment un e-mail expliquant les changements qu'implique pour vous le PHP Extended Support. Il est probable que vous ne l'ayez pas vu. Veuillez vérifier que l'adresse dont dispose STRATO est toujours valide, car c'est à cette adresse que nous vous envoyons les informations relatives au contrat. Nous vous expliquons ici comment vérifier et changer l'adresse e-mail dont dispose STRATO : Comment puis-je mettre à jour mes données contractuelles ?

 

Pourquoi le PHP Extended Support de STRATO est-il payant ?

Le PHP Extended Support est une prestation payante que nous mettons à disposition de nos clients Hébergement. La communauté PHP ayant cessé d'offrir un support pour les versions les plus anciennes, STRATO a pris en charge la maintenance active de ces versions PHP obsolètes. Le PHP Extended Support de STRATO couvre au-delà de la version 5.3 toutes les versions PHP obsolètes qui cesseront de bénéficier de support. Nous pouvons offrir ainsi un service sans interruptions de votre présence web et éviter que votre site web soit attaqué en raison d'une version obsolète.

 

Vous trouverez ci-après davantage de détails sur les différentes phases de support PHP ainsi que sur tout le cycle de vie PHP :

Qu'est-ce que le PHP Extended Support de STRATO ?-1.png

 

Les versions anciennes de PHP dans les espaces web de nos clients risquent de générer de potentielles vulnérabilités et de mettre en danger notre plate-forme d'hébergement et donc la sécurité de nos clients. Selon nos CGV, en tant que client STRATO, vous êtes obligé de maintenir votre logiciel toujours à jour. Si vous ne respectez pas cette obligation, nous devons nous charger de corriger les éventuelles vulnérabilités.

 

La maintenance de l'ancienne version PHP implique de grands efforts de gestion dans nos systèmes. Pour ce service supplémentaire, nous vous facturons un tarif économique mensuel afin de couvrir les coûts générés. Considérant que vous avez besoin des scripts PHP disponibles pour gérer votre site web, nous avons déjà activé le PHP Extended Support de STRATO pour votre contrat. Ainsi, les anciens scripts PHP continueront de fonctionner à l'avenir. Vous avez reçu des informations à ce sujet par e-mail.

 

Quand débute le PHP Extended Support de STRATO ?

Le PHP Extended Support payant de STRATO pour la version 7.1 débute le 01.12.2019.

 

Pour les nouvelles versions, le PHP Extended Support de STRATO sera lancé dès la que la communauté PHP cessera de l'offrir. À partir de ce moment, la version PHP ne sera plus maintenue et les vulnérabilités ne seront plus corrigées par la communauté PHP.

 

Pendant les 6 premiers mois, le PHP Extended Support de STRATO est gratuit. Indépendamment du fait que la communauté PHP cesse de fournir un support, nous vous conseillons de toujours utiliser une version PHP récente et reconnue.

 

Vous n'êtes pas sûr d'avoir besoin du PHP Extended Support ?

Vous pouvez tester en quelques étapes si votre site web fonctionne aussi avec les nouvelles versions PHP. Afin de minimiser les risques de rendre votre site temporairement indisponible, nous vous conseillons de procéder ainsi :

 

• Créez un sous-domaine et redirigez-le vers le nouveau dossier.

• Créez un sous-domaine et redirigez-le au nouveau dossier.

• Ensuite, dans le dossier, vous pourrez passer à la nouvelle version PHP 7.3 à travers .htaccess.

 

Ouvrez votre site web à travers le sous-domaine et vérifiez si tout fonctionne correctement. Si votre site web s'exécute sans problèmes, alors vous pouvez changer définitivement la version PHP dans votre Espace client pour votre site web. Vous trouverez des explications étape par étape dans notre article : Comment modifier la configuration PHP dans votre pack Hébergement

 

 

ATTENTION ! Après le changement et la déconnexion de votre Espace client vous ne pourrez plus restaurer la version. Vous devez donc vous assurer que votre site web fonctionne sous une version à jour avant de vous déconnecter de votre Espace client.

 

Vous souhaitez adapter vos scripts à une version PHP supérieure mais vous avez besoin de plus de temps ?

Vérifiez tout d'abord s'il est nécessaire d'effectuer une modification de vos scripts. De nombreux scripts sont compatibles et fonctionnent avec des versions mises à jour de PHP. Si ce n'est pas votre cas et que vous avez besoin de grandes modifications de vos scripts, vous pouvez continuer à utiliser le PHP Extended Support de STRATO jusqu'à ce que vous soyez prêt à changer à une version plus récente.

 

Comment désactiver STRATO PHP Extended Support ?

Une fois connecté dans votre espace client,

Vous cliquez en haut sur le bouton "Mes packs" et en suite sur le bouton "La liste de mes contrats".Vous sélectionnez votre contrat.

Après dirigez-vous à gauche vers le menue « Bases de données et espace web » Et ensuite sur « Définir la version PHP »

 Qu

Vous sélectionnez la Version Gratuite et vous confirmez en cliquant sur le bouton « OK ».

Qu

Vous recevez une confirmation de changement. Vous cliquez sur le bouton «Retour ».

Qu

En haut à côté de « STRATO Extended Support payant: active » vous cliquez sur le bouton « Désactiver »

Qu

A la fin une fenêtre (Désactiver l'Extended Support) s'ouvrira ou vous devriez encore confirmer les 3 options + le BOUTON « Désactiver l'Extended Support » pour désactiver définitivement PHP Extended Support de STRATO.

Qu

 

Vous souhaitez adapter vos scripts à une version PHP supérieure mais vous avez besoin de plus de temps ?

 

Vérifiez tout d'abord s'il est nécessaire d'effectuer une modification de vos scripts. De nombreux scripts sont compatibles et fonctionnent avec des versions mises à jour de PHP. Si ce n'est pas votre cas et que vous avez besoin de grandes modifications de vos scripts, vous pouvez continuer à utiliser le PHP Extended Support de STRATO jusqu'à ce que vous soyez prêt à changer à une version plus récente.

×